const regex = /^Discount\s(\d+(\.\d+)?)%$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Discount\\s(\\d+(\\.\\d+)?)%$', '')
const str = `Discount 1030.3%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}