// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)RIJDEN\?\s*(.+?)(?:\R+\d|\R*$)").unwrap();
let string = "testtestest
1. QUESTION QUESTION RIJDEN?
Txt pour regex1
2. QUESTION QUESTION BESTUURDER Txt p0ur regex2,
3. QUESTION QUESTION /POSTCODE)
Txt pour regex3;rz
Fin";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}