$re = '/(.*?),(.*?),/';
$str = 'accountnumber,10000,accountname,Nachiket,balance,null,age,38';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);