import re
regex = re.compile(r"^http(s)?://(www\.)?facebook.([a-z]+)/(?!(?:video\.php\?v=\d+|usernameFB/videos/\d+)).*$", flags=re.MULTILINE)
test_str = ("https://www.facebook.com/video.php?v=100000000000000\n"
"https://www.facebook.com/username1/videos/100000000000000\n"
"https://www.facebook.com/username2/videos/100000000000000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")