const regex = /\"Data Flow Task:Error: There was an error with Insert Destination\.Inputs\[OLE DB Destination Input\]\.Columns\[(.*?)\] on Insert Destination\.Inputs\[OLE DB Destination Input\]\. The column status returned was\: "The value violated the integrity constraints for the column\."\./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"Data Flow Task:Error: There was an error with Insert Destination\\.Inputs\\[OLE DB Destination Input\\]\\.Columns\\[(.*?)\\] on Insert Destination\\.Inputs\\[OLE DB Destination Input\\]\\. The column status returned was\\: "The value violated the integrity constraints for the column\\."\\.', '')
const str = `"Data Flow Task:Error: There was an error with Insert Destination.Inputs[OLE DB Destination Input].Columns[EmissionMarket] on Insert Destination.Inputs[OLE DB Destination Input]. The column status returned was: "The value violated the integrity constraints for the column.".`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}