$re = '/(?<=\?l=)(\S*)(?=\")/';
$str = '<img src="http://example.com/asset/test.gif?l=j6%2BNsqLlmq%2B7xLVmX4bLS50JYKpDzeoBjGl7Y6ti04qV%2BiEVQY0aFBoTKmamyAwv">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);