# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?) : (.+? MB\/s)( \[.*)?$"
test_str = ("Sequential Read : 135.091 MB/s\n"
"Sequential Write : 126.046 MB/s\n"
"Random Read 512KB : 44.569 MB/s\n"
"Random Write 512KB : 117.965 MB/s\n"
"Random Read 4KB (QD=1) : 0.468 MB/s [ 114.4 IOPS]\n"
"Random Write 4KB (QD=1) : 8.412 MB/s [ 2053.6 IOPS]\n"
"Random Read 4KB (QD=32) : 0.654 MB/s [ 159.6 IOPS]\n"
"Random Write 4KB (QD=32) : 10.751 MB/s [ 2624.7 IOPS]\n"
"Test : 1000 MB [C: 7.3% (64.9/889.4 GB)] (x5)\n"
"Date : 2015/12/09 22:06:02\n"
"OS : Windows 8.1 [6.3 Build 9600] (x64)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.