using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";(?![^""]*(([^""]*""[^""]*""){2})*[^""]*""[^""]*$)";
string input = @"STOPATDESK YES;
:: TXT ""LCLLMT:29.4700"";
:: TXT ""LCLCURR;NON-USD"";
:: TXT ""CALLBK:3"";
:: TXT ""FFTRL:EUR-LIM;-TAP-5"";
STOPATDESK YES; :: TXT ""LCLLMT:29.4700""; :: TXT ""LCLCURR;NON-USD""; :: TXT ""CALLBK:3""; :: TXT ""FFTRL:EUR-LIM;-TAP-5"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}