const regex = /^(\p{Lu}\p{L}*):\h*(.+?)(?:\h-\h(.+))?$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\p{Lu}\\p{L}*):\\h*(.+?)(?:\\h-\\h(.+))?$', 'gmu')
const str = `Asia: Asian Cup - Play Offs
Asia: Asian Cup
Asia: World Cup - Qualification - First Stage
Australia: A-League
Belgium: Jupiler League - Championship Group
Brazil: Série A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}