package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`param[12]=(\w+)`)
var str = `http://example.com/conversion/?param1=dhkw121?param2=dhja143&uuid=jsbdwbjb-fwjdbw-wdvvw-wj
http:// example.com/conversion/param1=dhkw121%uuid=dbjbjbcs-fbsj-fsjbjs-fsj/param2=dhja143`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}