re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[^a-zA-Z0-9\s]).{8,}$/m
str = 'Passw0rµ
Password
Passw0rd
passw0rµ
PASSW0Rµ
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end