$re = '/[,\s]*(?<key>\b[^:,]+?): (?<value>.*?(?=$|,\s+\b[^:,]+: ))/';
$str = 'a long key: with some long value, KeyA: ValueA, KeyB: ValueB, KeyC: ValueC, ValueD, ValueE, some text and https://www.example.orf, KeyF: 84,3 kg, KeyG: 34,3 x 234,3 x 54 cm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);