$re = '/^([a-zA-Z0-9.]+[ ]{1}[a-zA-Z0-9]+)*$/m';
$str = 'Dr. Smith
foo.bar
Dr. Jones
Dr. Wilkinson';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);