# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>(?'protocol'[a-zA-Z]+)://)?(?'domain'[a-zA-Z0-9.\-_]*)?(?>:(?'port'\d{1,5}))?/(?'path'[a-zA-Z0-9_\-%]+)(?:(?>\?(?'query'[a-zA-Z0-9_\-=&%]+))()|(?>#(?'anchor'[a-zA-Z0-9_\-%]+))()){0,2}$"
test_str = ("https://localhost:5000/test?id=10&class=5#header\n"
"http://example.com:443/test#header\n"
"ws://example.com/test?id=10&class=5\n"
"/test?id=10&class=5\n"
"/test?t=10\n"
"/test#10\n"
"/test%20test\n"
"/test#10?data=test")
subst = "protocol: ${protocol}\\nhost name: ${domain}\\nport: ${port}\\npath: /${path}\\nquery: ${query}\\nanchor: ${anchor}\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.