import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^=+(([^=])*)=+(?=\\\\n)";
final String string = "==== Section Header ====\\n\n"
+ "Section text goes here\\n\n"
+ "Another line\\n\n"
+ "Yet another line\\n\n"
+ "One more line for good measure\\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}