re = /^(0[1-9]|[1-2][0-9]|31(?!(?:0[2469]|11))|30(?!02))(0[1-9]|1[0-2])([12]\d{3})$/m
str = '31042001
04312001
20010431
20013104'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end