$re = '/WikiProject Banner Shell(?!\|1=)/mi';
$str = '{{WikiProject banner shell|
{{WikiProject banner shell|1=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);