$re = '/(?<=>)\s+(?=<)/m';
$str = '<h1>tag1</h>
<p>Between h ad p we have \\s and \\n</p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;