package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\\\/\?\[\]\*]+)`)
var str = `aeb//\sderr/?*/68897/[]?*555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}