package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\/::\s?([^\r\n]+?)[\r\n]`)
var str = `div
//:: Welcome to stuff!
h1=T['welcome']`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}