import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((u|is|has)\\-[a-z0-9][a-zA-Z0-9]*|([A-Z][a-zA-Z0-9]*(__[a-z0-9][a-zA-Z0-9]*)?(--[a-z0-9][a-zA-Z0-9]*)?))$";
final String string = "is-state\n"
+ "is-State\n"
+ "is-stateActive2\n"
+ "u-utility\n"
+ "u-Utility\n"
+ "u-utilityClass2\n"
+ "has-child\n"
+ "has-Child\n"
+ "has-childClass2\n"
+ "his-child\n"
+ "a-child\n"
+ "1-child\n"
+ "A-child\n"
+ "js-test\n\n"
+ "Block\n"
+ "Block--mod\n"
+ "Block__el\n"
+ "Block__el--mod\n\n"
+ "BlockBox\n"
+ "BlockBox--modMod\n"
+ "BlockBox__elEl\n"
+ "BlockBox__elEl--modMod\n\n"
+ "block-box\n"
+ "Block-box\n"
+ "blockBox\n"
+ "5block\n\n"
+ "B__m--e\n"
+ "B__M--E\n"
+ "B__m--E\n"
+ "B__M--e\n"
+ "b__M--E\n"
+ "b__m--E\n"
+ "b__M--e\n"
+ "b__m--e\n\n"
+ "B__m__e\n"
+ "B--m--e\n"
+ "B--m__e\n"
+ "B_m-e\n"
+ "B-m_e\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}