package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w(?:\s[+*]\s\w)+$`)
var str = `a + b
2 + a + b
3 + 6 * 9 + 6 * 5 + a * b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}