re = /([Gg][Ii][Rr] 0[Aa]{2})|((([A-Za-z][0-9]{1,2})|(([A-Za-z][A-Ha-hJ-Yj-y][0-9]{1,2})|(([A-Za-z][0-9][A-Za-z])|([A-Za-z][A-Ha-hJ-Yj-y][0-9][A-Za-z]?))))\s?[0-9][A-Za-z]{2})/m
str = 'c25d4f64-2336-4a5d-b94c-14dc12xxxa58
AB11AB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end