import Foundation
let pattern = #"u'([^']+)': u'([^']+)'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
dep14.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep24.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep21.cap1-infra.gsnetcloud.corp', u'srvcap101cnodep23.cap1-infra.gsnetcloud.corp']" id="4" name="local_disks_host_aggregate" properties="{u'cpu_allocation_ratio': u'1.0', u'disks.local': u'true', u'ram_allocation_ratio': u'1.0', u'ephem.ssd': u'false', u'disks.max': u'9'}" updated_at="None" region=CAP1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)