$re = '/(
[A-Z] # Look for a capital letter
[A-Za-z\'\(\) ]+ # Look for letter, \'() or space
\b[v|V]\b # Look for letter \'v\' by itself
[A-Za-z\'\(\) ]+ # Look for letter, \'() or space
(.*?) # Match anything
[\[ ] # Look for space or [
\d+\ + # Look for number followed by spaces
\w+\ # Look for word followed by space
\d\d\d\d # Look for number followed by 4 spaces
[\] ] # Look for space or ]
)/mx';
$str = '1 "R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003",
2 "H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]",
3 \'\'\'GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND ERIC JOHN WATSON CA CA51/03 26 May 2003\'\'\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);