$re = '/(?|\[\'([^\']*(?:\'(?!])[^\']*)*)\'\]|\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\')/';
$str = '$_[\'text_[1]\'] = \'text_2 %d to \\\'%d\\\' of %d (%d text)\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);