$re = '/(\b\S+)(?:\s+\1\b)+/i';
$str = 'This this this this will remove remove remove all all all all all of a a a a a a a a stutterer\'s stutterer\'s duplicate words words words';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;