using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:<br\s*\/?>\R?){2})\h+";
string substitution = @"$1";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed et nisl nulla. Aenean interdum eget augue vehicula commodo. Etiam condimentum pretium erat, porta venenatis mauris aliquam sed. Vestibulum non sapien ut dolor tincidunt mattis. Fusce a ullamcorper turpis. Nunc tincidunt lacus a sapien tempor sollicitudin. Donec eleifend augue augue, id maximus purus ultrices sit amet. Integer tortor magna, vulputate ut ipsum a, malesuada venenatis ligula. Quisque id tincidunt nibh. Cras blandit fringilla tellus, eget tincidunt lectus accumsan vitae. Fusce in tempor arcu.<br/>
<br>
Nunc lacinia dui eget volutpat porta. Morbi eu magna ornare, facilisis risus eget, varius sem. Proin hendrerit lacus condimentum, ullamcorper sem ac, tempus tellus. Fusce id odio vitae ante auctor congue. Morbi eget interdum sem. Duis vel tempor mi, feugiat accumsan urna. Proin in nulla sed enim ultricies posuere. Nullam molestie ligula scelerisque, feugiat eros ac, efficitur nisl.<br/>
<br>
Duis eget vehicula orci. Curabitur laoreet velit sit amet ligula congue, eget consectetur risus ultricies. Curabitur dictum felis at orci suscipit, sed pharetra diam vulputate. Nunc non nulla mi. Aliquam at dui ut nulla rhoncus hendrerit. Mauris sit amet hendrerit elit, vel vehicula felis. Fusce condimentum iaculis tellus, quis ornare urna. Sed lectus libero, viverra ut felis nec, sagittis rhoncus lectus. In vel erat nec ligula convallis euismod vel vitae diam.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}