re = /(\w+)\s?:\s?([^"\s]\S*[^"])/m
str = 'filename:"\\temp location\\files\\here" fileType:html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end