re = /[^.?!]*(?<=[.?\s!])was exactly(?=[\s.?!])[^.?!]*[.?!]/im
str = 'As she did so, a most extraordinary thing happened. The bed-clothes gathered themselves together, leapt up suddenly into a sort of peak, and then jumped headlong over the bottom rail.
It was exactly as if a hand had clutched them in the centre and flung them aside .
Immediately after, .........'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result