re = /^(?<startwort>AB[\w\d]+[a-zA-Z-]*)\s+(?<startplus>(AB[\w\d-]+[,]*\s+)*)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$/
str = 'AB2001482 AB0783714, AB0783714-Q ABBILD NRRHLAT 10 XäZ 207,25'
# Print the match result
str.match(re) do |match|
puts match.to_s
end