re = /\b[-0-9a-zA-Z.+_]+@[-0-9a-zA-Z.+_]+\.[a-zA-Z]{2,4}\b/m
str = 'My email id is xyz@mail.com
Note my mail id, xyz@mail.com, so you can send a mail.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end