package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-h]{2}`)
var str = `abcdefgabcdefhabcabcdefdefgh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}