$re = '/^.*port=([[:digit:]]+).*$/';
$str = 'monitor_sock_raw1=socket,id=hmqmondev,port=55919,host=127.0.0.1,nodelay';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);