$re = '~(?:^\S+\.com/\w|\G(?!^))\w*+\K/~m';
$str = 'http://example.com/foo/12/jacket Input/Output';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);