# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*([<>])\s*|(\s)\s*)"
test_str = ("<ul class=\"list-group sidebar-nav-v1 margin-bottom-40\" id=\"menuHomeUserPrivate\"> \n"
" <li class=\"list-group-item active\">\n"
" <a id=\"to_ProfileOverall\" class=\"privateMenuLinkJS\"><i class=\"fa fa-bar-chart-o\"></i> Overall</a>\n\n\n"
" </li>\n"
" <li class=\"list-group-item list-toggle\">\n"
" <a data-toggle=\"collapse\" data-parent=\"#menuHomeUserPrivate\" href=\"#collapse-MoneyManage\" ><i class=\"fa fa-money\"></i> Invoice</a>\n"
" <ul id=\"collapse-MoneyManage\" class=\"collapse\">\n"
" <li><a id=\"to_MoneyManagerFaturamentoInsert\" class=\"privateMenuLinkJS\"><i class=\"fa fa-level-down\"></i> Big Invoice </a></li>\n"
" <li><a id=\"to_MoneyManagerFaturamentoGerir\" class=\"privateMenuLinkJS\"><i class=\"fa fa-cogs\"></i> Big big big\n"
" \n"
" Invoice 2 </a></li>\n"
" </ul>\n"
" </li>\n"
" </ul>")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.