$re = '/data-title=\"(.*?)\"/';
$str = '<div class="url-block"><a href="https://developers.google.com/speed/docs/insights/OptimizeImages" target="_blank">Optimize the following images</a> to reduce their size by 231.2KiB (55% reduction).<ul><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/05/ban-tra-go-cong-nghiep-hien-dai-ghs-4188-1-1b-350x350.jpg">http://gotrangtri.vicoders.com/…ghiep-hien-dai-ghs-4188-1-1b-350x350.jpg</span> could save 36.3KiB (85% reduction).</li><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/05/ban-tra-go-cong-nghiep-phong-khach-ghs-4193-23-350x350.jpg">http://gotrangtri.vicoders.com/…hiep-phong-khach-ghs-4193-23-350x350.jpg</span> could save 34.3KiB (85% reduction).</li><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/04/ban-tra-go-cong-nghiep-hien-dai-ghs-4155-23-350x350.jpg">http://gotrangtri.vicoders.com/…-nghiep-hien-dai-ghs-4155-23-350x350.jpg</span> could save 31.5KiB (86% reduction).</li><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/05/ban-tra-phong-khach-go-cong-nghiep-ghs-4185-13-350x350.jpg">http://gotrangtri.vicoders.com/…h-go-cong-nghiep-ghs-4185-13-350x350.jpg</span> could save 27KiB (86% reduction).</li><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/05/ke-tivi-go-cong-nghiep-hien-dai-ghs-3194-13-350x350.jpg">http://gotrangtri.vicoders.com/…-nghiep-hien-dai-ghs-3194-13-350x350.jpg</span> could save 24.4KiB (83% reduction).</li><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/07/banner-xa-kho-noi-that-7.gif">http://gotrangtri.vicoders.com/…ads/2016/07/banner-xa-kho-noi-that-7.gif</span> could save 22.2KiB (40% reduction).</li><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/04/ke-tivi-phong-khach-kieu-dang-hien-dai-ghs-363-7b-350x350.jpg">http://gotrangtri.vicoders.com/…ieu-dang-hien-dai-ghs-363-7b-350x350.jpg</span> could save 21.1KiB (85% reduction).</li><li>Compressing and resizing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/06/tu-de-giay-nho-phong-cach-hien-dai-ghs-5129-13b-350x350.jpg">http://gotrangtri.vicoders.com/…g-cach-hien-dai-ghs-5129-13b-350x350.jpg</span> could save 18.5KiB (83% reduction).</li><li>Losslessly compressing <span class="url-external" data-title="http://gotrangtri.vicoders.com/wp-content/uploads/2016/07/banner-gio-vang-go-home2.gif">http://gotrangtri.vicoders.com/…ads/2016/07/banner-gio-vang-go-home2.gif</span> could save 8.9KiB (14% reduction).</li><li>Losslessly compressing <span class="url-external" data-title="http://gotrangtri.vn/wp-content/uploads/2016/01/banner-icon-ngo-nghinh-san-.gif">http://gotrangtri.vn/…/2016/01/banner-icon-ngo-nghinh-san-.gif</span> could save 7.1KiB (11% reduction).</li></ul></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);