$re = '/\s*(Name)\s*=\s*(.+)\s*/';
$str = ' Name = Peppa Pig ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);