re = /^(?=.*a)(?=.*b)(?=.*c)[a-z]+$/m
str = 'wyyga
qwertyuioplkjhgfdsazxcvbnm
ejuxggfsts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end