const regex = new RegExp('(\\d+)(?=[._])', 'g')
const str = `\\listName 082713\\type_102113\\25765199.bpo.pdf
\\list\\listName 082713\\type_102113\\25765280.bpo.pdf
\\list\\listName 082713\\type_102113\\25779752.bpo.pdf
\\list\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf
\\list\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf
\\list\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf
a:\\listName 082713\\type_102113\\25765199.bpo.pdf
a:\\listName 082713\\type_102113\\25765280.bpo.pdf
a:\\listName 082713\\type_102113\\25779752.bpo.pdf
a:\\listName 082713\\type_102113\\NAME1 0020412714_BPO.pdf
a:\\listName 082713\\type_102113\\NAME2 0020421822_BPO.pdf
a:\\listName 082713\\type_102113\\NAME3 0020443370_BPO.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}