$re = '/identifier:([0-9]*)/m';
$str = 'https://test.com/identifier:1234?item=123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);