$re = '/([-.]?\d+(?:\.\d+)?)/';
$str = 'M0.286-3.099-0.44c-2.901,-0.436,,,123,0.123,.34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);