#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\[ (?# match [ literally)" & @CRLF & _
"( (?# start capture group)" & @CRLF & _
" http (?# match http literally)" & @CRLF & _
" \S+ (?# match 1+ non-whitespace characters)" & @CRLF & _
") (?# end capture group)" & @CRLF & _
"\s+ (?# match 1+ whitespace characters)" & @CRLF & _
"( (?# start capture group)" & @CRLF & _
" [^\]]+ (?# match 1+ non-] characters)" & @CRLF & _
") (?# end capture group)" & @CRLF & _
"\] (?# match ] literally)" & @CRLF & _
"(?: (?# start non-capturing group)" & @CRLF & _
" \s+ (?# match 1+ whitespace characters)" & @CRLF & _
" from (?# match from literally)" & @CRLF & _
" (?: (?# start non-capturing group)" & @CRLF & _
" \s+ (?# match 1+ whitespace characters)" & @CRLF & _
" the (?# match the literally)" & @CRLF & _
" )? (?# end optional non-capturing group)" & @CRLF & _
" \s+ (?# match 1+ whitespace characters)" & @CRLF & _
" \[\[ (?# match [[ literally)" & @CRLF & _
" ( (?# start capturing group)" & @CRLF & _
" .*? (?# lazily match 0+ characters)" & @CRLF & _
" ) (?# end capturing group)" & @CRLF & _
" \]\] (?# match ]] literally)" & @CRLF & _
")? (?# end optional non-caputring group)"
Local $sString = "{{Wikibooks|Wikijunior:Countries A-Z|France}} {{Sister project links|France}} * [http://www.bbc.co.uk/news/world-europe-17298730 France] from the [[BBC News]] * [http://ucblibraries.colorado.edu/govpubs/for/france.htm France] at ''UCB Libraries GovPubs'' *{{dmoz|Regional/Europe/France}} * [http://www.britannica.com/EBchecked/topic/215768/France France] ''Encyclopædia Britannica'' entry * [http://europa.eu/about-eu/countries/member-countries/france/index_en.htm France] at the [[European Union|EU]] *{{Wikiatlas|France}} *{{osmrelation-inline|1403916}} * [http://www.ifs.du.edu/ifs/frm_CountryProfile.aspx?Country=FR Key Development Forecasts for France] from [[International Futures]] ;Economy *{{INSEE|National Institute of Statistics and Economic Studies}} * [http://stats.oecd.org/Index.aspx?QueryId=14594 OECD France statistics]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")