import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "2014(?:(?!2014).)*?baloon(?:(?!2014).)*?(?=\\n2014)";
final String string = "2014.10.30: b\n"
+ "l\n"
+ "ah bl\n"
+ "a\n"
+ "h \n"
+ "2014.10.30: bfoo \n"
+ "lah \n"
+ "b \n"
+ "l \n"
+ "ah \n"
+ "2014.10.30: bart1\n"
+ "lah \n"
+ "baloon \n"
+ "l \n"
+ "ah \n"
+ "2014.10.30: carb \n"
+ "lah \n"
+ "b \n"
+ "l \n"
+ "ah \n"
+ "2014.10.30: farb2 \n"
+ "lah \n"
+ "baloon \n"
+ "l \n"
+ "ah \n"
+ "2014.10.30: carb \n"
+ "lah \n"
+ "b \n"
+ "l \n"
+ "ah \n"
+ "2014.10.30: bom \n"
+ "lah \n"
+ "baloob \n"
+ "l \n"
+ "ah \n"
+ "etc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}