#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[^0-9a-zA-z.\s!"#$%&'()*+,\-./:;<=>?" & @CRLF & _
"@[\]\^_" & @CRLF & _
"`{|}~。「」、・ヲァィゥェォャュョッーアイウエオカキクケコサシスセソ" & @CRLF & _
"タチツテトナニヌネノハヒフヘホマミムメモヤユヨラリルレロワン゙゚]+$"
Local $sString = "わたしは今日は!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")