package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(?:[^><]+|<(?:[^><]+|<[^><]*>)*>)*>`)
var str = `<TEXTTYPE:<F3>><MSD:100><TEXTTYPE:),(1/3))<ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT><ARROW LEFT>><MSD:100><TEXTTYPE:<CTRLD><SHIFTD>]<SHIFTU><CTRLU>><MSD:500><TEXTTYPE:<ARROW LEFT>pow(>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}