$re = '/^(\w)(\d)\1\2$/';
$str = 'a3a3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);