using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^\d)(^.*?$)";
string input = @"1 number as the first character makes the segment fail to satisfy the ccondition.
This is a segment that satisfies the condition, because it does not start with a single-digit number.
1This segment does not.
12345
The segment above also didn't.
1. this is another example of a non-match.
This other segment, on the other hand, is a match.
This 1 2.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}