# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[:,]\s*=?\s*(?:([A-Z][a-z]+(?:\s[A-Z][a-z]+)?))?\s*=?\s*.*?([\w.]+@[\w.-]+)"
test_str = (" > Begin forwarded message:\n"
">=20\n"
"> Date: December 20, 2013 at 11:32:39 AM GMT-3\n"
"> Subject: My dummy subject\n"
"> From: Charlie Brown <aaa@aa-aaa.com>\n"
"> To: maria.brown@aaa.com, George Washington <george@washington.com>, =\n"
"thomas.jefferson@aaa.com, thomas.alva.edison@aaa.com, Juan =\n"
"<juan@aaa.com>, Alan <alan@aaa.com>, Alec <alec@aaa.com>, =\n"
"Alejandro <aaa@aaa.com>, Alex <aaa@planeas.com>, Andrea =\n"
"<andrea.mery@thomsen.cl>, Andrea <andrea.22@aaa.com>, Andres =\n"
"<andres@aaa.com>, Andres <avaldivieso@aaa.com>\n"
"> Hi,\n"
"> Please reply ASAP with your RSVP\n"
"> Bye")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.